CVE-2022-3275 - Puppetlabs-apt Command Injection

 

  • Posted 2022-10-03

  • Assessed Risk Level: High

  • CVSS 3.1 Base Score: 8.4

Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.

Status

Affected software versions:

  • Puppetlabs-apt module <9.0.0

Resolved in:

  • Puppetlabs-apt module 9.0.0